Lampwrights Forum > Other Stuff > vBulletin Wordpress Bridge

Reply
 
Thread Tools
02-02-2011, 10:20 PM   #1
NSA
Junior Member
 
Join Date: Feb 2011
Posts: 5
Rep Power: 0
NSA is getting browny points
Red face Strange WP behavior since install

Hello!

Thank you for the work you've done on the WP/VB bridge.. it's a great plugin!

I installed the software tonight, and its mostly working, but for some reason when I post a new post in WP the "user" shows up as some other user from the VB database.

It's the same VB user for me every time I post, and same for the other editors/administrators. I assume it's linking the existing WP accounts with someone elses VB account?

Any help you could provide would be awesome, thank you!
NSA is offline   Reply With Quote

02-03-2011, 01:09 AM   #2
freak99
Junior Member
 
Join Date: Feb 2011
Posts: 20
Rep Power: 0
freak99 is getting browny points
Quote:
Originally Posted by NSA View Post
Hello!

Thank you for the work you've done on the WP/VB bridge.. it's a great plugin!

I installed the software tonight, and its mostly working, but for some reason when I post a new post in WP the "user" shows up as some other user from the VB database.

It's the same VB user for me every time I post, and same for the other editors/administrators. I assume it's linking the existing WP accounts with someone elses VB account?

Any help you could provide would be awesome, thank you!
I have a similar issue. The existing WP posts show a user from the vb database who is not the author.
freak99 is offline   Reply With Quote
02-03-2011, 05:24 PM   #3
Jeff
Administrator
 
Jeff's Avatar
 
Join Date: Jul 2010
Posts: 402
Rep Power: 10
Jeff is getting browny points
The WP post is from a WP user. You must still have modified templates from the old bridge.
Jeff is offline   Reply With Quote
02-03-2011, 08:44 PM   #4
NSA
Junior Member
 
Join Date: Feb 2011
Posts: 5
Rep Power: 0
NSA is getting browny points
Quote:
Originally Posted by Jeff View Post
The WP post is from a WP user. You must still have modified templates from the old bridge.
This was the first bridge from you that we've installed on the site, downloaded the new version you released a couple of days ago.

All of the WP posts have VB usernames now. To login to the WP Control Panel I still use my old WP admin account, and everything shows up correctly in the WP Control Panel (Author, etc). But when I publish a post the author shows up as a certain VB user (Each Author seems to point to a certain other VB user).

Any help you can provide would be great, I am not even sure where to start looking!
NSA is offline   Reply With Quote
02-04-2011, 01:17 AM   #5
freak99
Junior Member
 
Join Date: Feb 2011
Posts: 20
Rep Power: 0
freak99 is getting browny points
Quote:
Originally Posted by Jeff View Post
The WP post is from a WP user. You must still have modified templates from the old bridge.
This is also the first time I've installed this product and my issue is similar. I haven't added any news posts yet, but existing posts display with a random vb user name instead of the actual user name in WP.

This happens on the article pages, in the tagline under the title. The WP author shows as some random VB user. Not sure if it matters, but the exact author name from WP doesn't exist in VB, does that matter?
freak99 is offline   Reply With Quote
02-04-2011, 03:01 PM   #6
Jeff
Administrator
 
Jeff's Avatar
 
Join Date: Jul 2010
Posts: 402
Rep Power: 10
Jeff is getting browny points
Ok, I found the bug and have fixed it. Download the latest version and overwrite the files with the new ones.

Thanks for the heads up!
Jeff is offline   Reply With Quote
02-04-2011, 06:33 PM   #7
freak99
Junior Member
 
Join Date: Feb 2011
Posts: 20
Rep Power: 0
freak99 is getting browny points
Quote:
Originally Posted by Jeff View Post
Ok, I found the bug and have fixed it. Download the latest version and overwrite the files with the new ones.

Thanks for the heads up!
Jeff, I'm now receiving a "headers already sent" error. It seems only happen when not logged in.
freak99 is offline   Reply With Quote
02-04-2011, 06:56 PM   #8
Jeff
Administrator
 
Jeff's Avatar
 
Join Date: Jul 2010
Posts: 402
Rep Power: 10
Jeff is getting browny points
Did you disable plugins in your WORDPRESS control panel VBridge settings?

Vbridge Settings -> Enable plugins during wordpress instance (NO)

99.9999999999% of the time you want this set to no.
Jeff is offline   Reply With Quote
02-04-2011, 07:11 PM   #9
Jeff
Administrator
 
Jeff's Avatar
 
Join Date: Jul 2010
Posts: 402
Rep Power: 10
Jeff is getting browny points
That is user settings, not vbridge settings.. It is located in the settings menu.
Jeff is offline   Reply With Quote
02-04-2011, 07:15 PM   #10
freak99
Junior Member
 
Join Date: Feb 2011
Posts: 20
Rep Power: 0
freak99 is getting browny points
Quote:
Originally Posted by Jeff View Post
Did you disable plugins in your WORDPRESS control panel VBridge settings?

Vbridge Settings -> Enable plugins during wordpress instance (NO)

99.9999999999% of the time you want this set to no.
That setting is set to no. I'm getting the error when I post a comment.

The comment posts, but the error pops up when the page tries to re-load.
freak99 is offline   Reply With Quote
02-04-2011, 07:22 PM   #11
freak99
Junior Member
 
Join Date: Feb 2011
Posts: 20
Rep Power: 0
freak99 is getting browny points
Quote:
Originally Posted by freak99 View Post
That setting is set to no. I'm getting the error when I post a comment.

The comment posts, but the error pops up when the page tries to re-load.
When the error page loads, the url in the address bar is: wp-comments-post.php.

Quote:
Warning: Cannot modify header information - headers already sent by (output started at /mypath/wp-content/plugins/vbbridge/vbbridge.php:457) in /mypath/wp-includes/pluggable.php on line 890
freak99 is offline   Reply With Quote
02-04-2011, 07:32 PM   #12
Jeff
Administrator
 
Jeff's Avatar
 
Join Date: Jul 2010
Posts: 402
Rep Power: 10
Jeff is getting browny points
Quote:
Originally Posted by freak99 View Post
When the error page loads, the url in the address bar is: wp-comments-post.php.
Hmm, there is nothing on that line (457).

I would check the file and make sure it was not corrupted. (vbbridge.php).
Jeff is offline   Reply With Quote
02-04-2011, 07:57 PM   #13
freak99
Junior Member
 
Join Date: Feb 2011
Posts: 20
Rep Power: 0
freak99 is getting browny points
Quote:
Originally Posted by Jeff View Post
Hmm, there is nothing on that line (457).

I would check the file and make sure it was not corrupted. (vbbridge.php).
I just re-downloaded and installed both php files again from scratch and I still receive the sam error, which oddly seems to be the last line of the file.

I'm also getting some garbled characters in the contents of my posts when the plugin is enabled, mosty: and ….

I supposed I'll wait and see if anyone else has issues. If not, it must be specific to my installation.

Thanks.
freak99 is offline   Reply With Quote
02-04-2011, 08:06 PM   #14
NSA
Junior Member
 
Join Date: Feb 2011
Posts: 5
Rep Power: 0
NSA is getting browny points
I am getting the same issue I believe...

The new files fixed the user issue though! Thanks!

This error is when I try to write a new post:

Quote:
Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/nsa/fighting118th/wp-content/plugins/vbbridge/vbbridge.php:457) in /usr/www/users/nsa/fighting118th/wp-includes/classes.php on line 1601


Then...

Quote:
Warning: Cannot modify header information - headers already sent by (output started at /usr/www/users/nsa/fighting118th/wp-content/plugins/vbbridge/vbbridge.php:457) in /usr/www/users/nsa/fighting118th/wp-includes/pluggable.php on line 890
NSA is offline   Reply With Quote
02-04-2011, 08:09 PM   #15
NSA
Junior Member
 
Join Date: Feb 2011
Posts: 5
Rep Power: 0
NSA is getting browny points
Note.. even though it errored.. it still posted the post to the front page.

And when it errors on commenting, it still posts the comment.
NSA is offline   Reply With Quote
02-04-2011, 08:19 PM   #16
Jeff
Administrator
 
Jeff's Avatar
 
Join Date: Jul 2010
Posts: 402
Rep Power: 10
Jeff is getting browny points
Hmm, this might have to do with the linefeeds used in my text editor. I have converted them to unix style line feeds. Please redownload the scripts and upload them to your server.
Jeff is offline   Reply With Quote
02-04-2011, 08:30 PM   #17
NSA
Junior Member
 
Join Date: Feb 2011
Posts: 5
Rep Power: 0
NSA is getting browny points
Success!

Tested posting a new post as well as commenting on an existing post and they both worked with flying colors!!

Thanks for fixing this.. I'll play around with it tonight and see if I can't break something else

Do you have any plans to add/change features in the future?

Thanks again!
NSA is offline   Reply With Quote
02-04-2011, 11:00 PM   #18
freak99
Junior Member
 
Join Date: Feb 2011
Posts: 20
Rep Power: 0
freak99 is getting browny points
Quote:
Originally Posted by Jeff View Post
Hmm, this might have to do with the linefeeds used in my text editor. I have converted them to unix style line feeds. Please redownload the scripts and upload them to your server.
That did it!!! Awesome job.

One other thing I see is that the logout link doesn't appear to work. I'm guessing that link needs to redirect to the vb logout script.

The only other tweak I would add pertains to guest comments. Ideally, I would like to require a user be logged into vb in order to leave a comment. Thoughts?

It would be incredible if the avatar from vb was used in the comments list. Any chance of adding that? That would make it perfect!!!

Thanks again.

Last edited by freak99; 02-04-2011 at 11:03 PM.
freak99 is offline   Reply With Quote
02-04-2011, 11:29 PM   #19
freak99
Junior Member
 
Join Date: Feb 2011
Posts: 20
Rep Power: 0
freak99 is getting browny points
Quote:
Originally Posted by freak99 View Post

The only other tweak I would add pertains to guest comments. Ideally, I would like to require a user be logged into vb in order to leave a comment. Thoughts?
I was thinking about this one. Obviously, it's possible to disable guest comments in the WP settings, so you would just need to replace the link in:

"You must log in to post a comment."

... to redirect to the vb login page instead of the WP login page.
freak99 is offline   Reply With Quote
02-05-2011, 03:20 AM   #20
freak99
Junior Member
 
Join Date: Feb 2011
Posts: 20
Rep Power: 0
freak99 is getting browny points
I don't mean to bombard your thread, but I wanted to point out one more issue that you may or may not be aware of. I use third party desktop software (Windows Live Writer on windows and ecto on Mac) to post to my blog. I noticed this evening that I'm not able to log in using these types of programs with your plugin enabled.

Thanks
freak99 is offline   Reply With Quote
Reply

Tags

vbulletin integration

,

vbulletin wordpress bridge


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 06:54 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.